• Online, Self-Paced
Course Description

This course explains how testers and developers can determine if their web applications are vulnerable to the A9:2017 security vulnerability, Using Components with Known Vulnerabilities, identified by the Open Web Application Security Project (OWASP). It also explains how to protect web applications against this vulnerability. In this course, you will learn how to test your application for using components with known vulnerabilities and you will learn how to protect your application against using components with known vulnerabilities.

Learning Objectives

On successful completion of this course, learners should have the knowledge and skills to:

  • Determine if a web application is vulnerable to Use of Components with Known Vulnerabilities
  • Explain how to protect the application against this security vulnerability

Framework Connections

The materials within this course focus on the Knowledge Skills and Abilities (KSAs) identified within the Specialty Areas listed below. Click to view Specialty Area details within the interactive National Cybersecurity Workforce Framework.